All systems operational

Show current status

[Resolved] Issue with API resulted in 25-mins downtime

Started on July 8, 2020 at 7:44 PM. Resolved after less than a minute

Affected

Sales Bot
  • Resolved
    July 8, 2020 at 7:44 PM  –  

    We just resolved the issue!