All systems operational

Show current status

[Resolved] Scroll issue still persisting for some users

Started on May 17, 2020 at 7:39 PM. Resolved after less than a minute

Affected

Depop App
  • Resolved
    May 17, 2020 at 7:39 PM  –  

    We just resolved the issue!