Show current status
[Resolved] Some users experiencing issues with scrolling in app
Started on May 15, 2020 at 7:37 PM. Resolved after less than a minute
Affected
Depop App
- Resolved
Started on May 15, 2020 at 7:37 PM. Resolved after less than a minute
Affected